Are you looking for test card numbers?

Would you like to contact support?

No momento, esta página não está disponível em inglês
Plugin icon

Migrating to a new version

Follow these instructions to migrate your Magento 2 plugin to a new major version

On this page, we describe the changes that you need to make in your existing integration when migrating to version 7.0.0 or version 8.0.0 of the Magento 2 plugin.

Step 1: Upgrade the plugin

Follow the instructions to upgrade the plugin to version 8.0.0.

Version 8.0.0 has breaking changes for merchants with a headless integration, so make sure to fully test your integration before going live if you are using this type of integration.

Migrating from version 6.0.0

If you are migrating your plugin from version 6.0.0 or earlier, follow these two steps first to comply with version 7.0.0 changes:

  1. Generate a client key
  2. Set up Apple Pay

After you have done the above, continue with Step 2: Verify your headless integration.

Step 2: Verify your headless integration

  1. From version 8.0.0 onwards, you have to use a Magento OAuth authenticated API integration. To do this, follow the Magento developer documentation:
    1. Add a new integration.
      1. For Resource Access select Custom. Select all the resources under the Adyen directory. Select Save.
    2. Activate your integration.
    3. When you send a request to one of the Adyen resources, include the Access Token of your integration in the Authorization header as a bearer token.
  2. Change the payment status call from a GET request to a POST request.

The Pay by Mail payment method is deprecated in version 8.0.0. If you want to send shoppers a payment link, you have to set up Pay by Link.

Step 4: Check dependencies

This version of the plugin uses Checkout API version 68 and Components version 5.2.0. If you have customized the plugin, upgrading could cause issues in the implementation of your custom code. Check if your integration is compatible with the new versions of Checkout API and Components and apply changes if needed.